$re = '/(\d+)_(\d+)/m';
$str = ' \\1800_411.pdf.log
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);