package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(app plex) ?(?:@(\S*))?`)
var str = `app plex @zycore look at this`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}