$re = '/(app plex) ?(?:@(\S*))?/m';
$str = 'app plex @zycore look at this';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);