package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[/]([^/?#]*)[/]?([^/?#]*)`)
var str = `/salud/pediatria/kitchen-emsinkem-story/?_website=tn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}