re = /^[\/]([^\/?#]*)[\/]?([^\/?#]*)/
str = '/salud/pediatria/kitchen-emsinkem-story/?_website=tn'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end