import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{1,2})[:. ]?(\\d{0,2})[:. ]?(\\d{0,2})[:. ]?([ap]?\\.?m\\.?)?";
final String string = "09:00:00\n"
+ "9:15\n"
+ "9.15\n"
+ "15:10\n"
+ "15:10:32\n"
+ "3:10 p.m.\n"
+ "3:10 pm\n"
+ "03:10:32 pm\n"
+ "10 am\n"
+ "10 a.m.\n"
+ "10am\n"
+ "10\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}