const regex = /^(\d{1,2})[:. ]?(\d{0,2})[:. ]?(\d{0,2})[:. ]?([ap]?\.?m\.?)?/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\d{1,2})[:. ]?(\\d{0,2})[:. ]?(\\d{0,2})[:. ]?([ap]?\\.?m\\.?)?', 'igm')
const str = `09:00:00
9:15
9.15
15:10
15:10:32
3:10 p.m.
3:10 pm
03:10:32 pm
10 am
10 a.m.
10am
10
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}