package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(0|(0(1|11)0))*$`)
var str = `00000011011100`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}