$re = '/^(0|(0(1|11)0))*$/';
$str = '00000011011100';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);