using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Tom(?!.*Thumb)";
string input = @"Tom Oh Thumb Here
Tom No T-humb Here";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}