$re = '/Tom(?!.*Thumb)/';
$str = 'Tom Oh Thumb Here
Tom No T-humb Here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);