#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[ABCEGHJKLMNPRSTVXY]\d[A-Za-z][ -]\d[A-Za-z]\d$"
Local $sString = "K1G" & @CRLF & _
"----====" & @CRLF & _
" K1G 6C9 " & @CRLF & _
"Z1R p90" & @CRLF & _
"w4t908" & @CRLF & _
"" & @CRLF & _
"w4r io9" & @CRLF & _
"yt4 g7y" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"K1G 6C9---" & @CRLF & _
"K1G 6C9====" & @CRLF & _
"K1G 6C9K1G 6C9" & @CRLF & _
"K1G 6C9K1G 6C9K1G 6C9" & @CRLF & _
"" & @CRLF & _
"K1G 6C9slkdjfsdklfjsdkjfhsdf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"$[ABCEGHJKLMNPRSTVXY][0-9][ABCEGHJKLMNPRSTVWXYZ]{3} $[0-9][ABCEGHJKLMNPRSTVWXYZ][0-9]{3}" & @CRLF & _
"" & @CRLF & _
"K1G 6C9" & @CRLF & _
"K1G6C9" & @CRLF & _
"L7J 0A1" & @CRLF & _
"L7J 0A2" & @CRLF & _
"L7J 0A3" & @CRLF & _
"L7J 0A4" & @CRLF & _
"L7J 0A5" & @CRLF & _
"L7J 0A6" & @CRLF & _
"L7J 0A7" & @CRLF & _
"L7J 2Y3" & @CRLF & _
"L7J 2Y4" & @CRLF & _
"L7J 2Y5" & @CRLF & _
"L7J 2Y6" & @CRLF & _
"L7J 2Y7" & @CRLF & _
"L7J 2Y8" & @CRLF & _
"L7J 2Y9" & @CRLF & _
"L7J 2Z1" & @CRLF & _
"L7J 2Z2" & @CRLF & _
"N0G 0B5" & @CRLF & _
"N0G 2X0" & @CRLF & _
"" & @CRLF & _
"W0G 0B5" & @CRLF & _
"Y0G 2X0" & @CRLF & _
"N0H 2T0" & @CRLF & _
"Z0G 2X0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")