import re
regex = re.compile(r"^[ABCEGHJKLMNPRSTVXY]\d[A-Za-z][ -]\d[A-Za-z]\d$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("K1G\n"
"----====\n"
" K1G 6C9 \n"
"Z1R p90\n"
"w4t908\n\n"
"w4r io9\n"
"yt4 g7y\n\n\n"
"K1G 6C9---\n"
"K1G 6C9====\n"
"K1G 6C9K1G 6C9\n"
"K1G 6C9K1G 6C9K1G 6C9\n\n"
"K1G 6C9slkdjfsdklfjsdkjfhsdf\n\n\n"
"$[ABCEGHJKLMNPRSTVXY][0-9][ABCEGHJKLMNPRSTVWXYZ]{3} $[0-9][ABCEGHJKLMNPRSTVWXYZ][0-9]{3}\n\n"
"K1G 6C9\n"
"K1G6C9\n"
"L7J 0A1\n"
"L7J 0A2\n"
"L7J 0A3\n"
"L7J 0A4\n"
"L7J 0A5\n"
"L7J 0A6\n"
"L7J 0A7\n"
"L7J 2Y3\n"
"L7J 2Y4\n"
"L7J 2Y5\n"
"L7J 2Y6\n"
"L7J 2Y7\n"
"L7J 2Y8\n"
"L7J 2Y9\n"
"L7J 2Z1\n"
"L7J 2Z2\n"
"N0G 0B5\n"
"N0G 2X0\n\n"
"W0G 0B5\n"
"Y0G 2X0\n"
"N0H 2T0\n"
"Z0G 2X0")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")