package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.net\b`)
var str = `"Visited xtreme.com, stupid.net, childish.com, happy.net and innocence.edu. There are some cross.network isssues that are to be fixed."`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}