re = /\.net\b/
str = '"Visited xtreme.com, stupid.net, childish.com, happy.net and innocence.edu. There are some cross.network isssues that are to be fixed."'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end