re = /HKEY_USERS\\[^\\]+Classes\\/mi
str = 'HKEY_USERS\\S-1-5-21-4238271725-2374787876-508243797-1000_CLASSES\\Local Settings\\MuiCache\\108\\A7EAB198\\@%SystemRoot%\\System32\\bthserv.dll,-102'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end