// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)HKEY_USERS\\[^\\]+Classes\\").unwrap();
let string = "HKEY_USERS\\S-1-5-21-4238271725-2374787876-508243797-1000_CLASSES\\Local Settings\\MuiCache\\108\\A7EAB198\\@%SystemRoot%\\System32\\bthserv.dll,-102";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}