package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)((?:"[^"]+")?[\w\.]+?) ?= ?((?:"[^"]+")|\w+)`)
var str = `KeylessBuy=f and not (Feedback.color = green or comment.color=green)
and not "BIN State".color = white and comment="got it right"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}