$re = '/((?:"[^"]+")?[\w\.]+?) ?= ?((?:"[^"]+")|\w+)/im';
$str = 'KeylessBuy=f and not (Feedback.color = green or comment.color=green)
and not "BIN State".color = white and comment="got it right"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);