using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"format\((.*), (.*), ""(.*)"", (.*)+\)";
string input = @"mformat(ee_stri, sizeof(ee_stri), "" %s (%d) po raz %d wygrał {b}/ws{/b}. I otrzymuje {b}%d Score i %d${/b} "", playerNick(script_ws[ winreed ]), script_ws[ winreed ], addPointEvent(script_ws[ winreed], stats_ws), score, kasy);
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}