import Foundation
let pattern = #"format\((.*), (.*), "(.*)", (.*)+\)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
mformat(ee_stri, sizeof(ee_stri), " %s (%d) po raz %d wygrał {b}/ws{/b}. I otrzymuje {b}%d Score i %d${/b} ", playerNick(script_ws[ winreed ]), script_ws[ winreed ], addPointEvent(script_ws[ winreed], stats_ws), score, kasy);
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}