package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9.]*`)
var str = `2323423423.423434234234`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}