$re = '/[0-9.]*/';
$str = '2323423423.423434234234';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);