re = /^(.*?)\/+$/m
str = 'http://example.com///
http://emy.dod.com/kaskaa/dkaiad/amaa//////////
http://www.example.com/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end