import re
regex = re.compile(r"[^A-Za-z0-9]")
test_str = ("RZL 200 -200 литров, Накопительный электроводонагреватель\n"
"EKH 50U-Вертикальный электроводонагреватель 50 литров\n"
"EKF 70U, Суперплоский электрический водонагреватель -70 литров, Глубина=320 мм\n"
"FF06 1/2\"AA фильтр механической очистки ,на холодную воду.\n"
"FF06 1\"AA, фильтр механической очистки на холодную воду.\n"
"F76 S 1/2\" AA (AB, AC, AD), фильтр механической очистки , на холодную воду\n"
"ProfiRoll-2000, 13,3-18,2, 2000 Вт, Телый пол в цементно-песчаную стяжку\n"
"ProfiMat 160-2,0 кв.м, 0,320 Вт\n"
"Набор №203 , Набор фильтрэлементов №203(A560,A-560E,Em,Ecp,A-575E,Em,Ecp)\n"
"A-575Ep box MAX, Система обратного осмоса, 5 ступеней очистки со встроенным баком, насосом повышения давления и индикатором качества воды, 380 л/сутки (Россия)\n"
"Емкость из ПЭ 1500 (ЕЭЦ1500) л, цилиндрическая вертикальная для питьевой воды\n"
"Алюминиевый радиатор HLA-12R-B\n"
"Система обогрева трубопроводов SLH 25/L30 ST\n"
"Нагревательный мат FFH 400/12,0\n"
"AF11S-1A,B,С,D,E,F.Запасная сетка для F76S,СS,FK76CS и HS10S (от 1/2\" до 11/4\"), 100,20,50,200,300,500микрон\n"
"Фильтр A-11 BE (BIG BLUE 10) В сборе с кронштейном,ключом и фильтрующим элементом,1 ступень очистки (механическая)\n"
"Комплект \"TROPIX\" МНН-130-1 (1 кв. метр)\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")