// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^A-Za-z0-9]").unwrap();
let string = "RZL 200 -200 литров, Накопительный электроводонагреватель
EKH 50U-Вертикальный электроводонагреватель 50 литров
EKF 70U, Суперплоский электрический водонагреватель -70 литров, Глубина=320 мм
FF06 1/2\"AA фильтр механической очистки ,на холодную воду.
FF06 1\"AA, фильтр механической очистки на холодную воду.
F76 S 1/2\" AA (AB, AC, AD), фильтр механической очистки , на холодную воду
ProfiRoll-2000, 13,3-18,2, 2000 Вт, Телый пол в цементно-песчаную стяжку
ProfiMat 160-2,0 кв.м, 0,320 Вт
Набор №203 , Набор фильтрэлементов №203(A560,A-560E,Em,Ecp,A-575E,Em,Ecp)
A-575Ep box MAX, Система обратного осмоса, 5 ступеней очистки со встроенным баком, насосом повышения давления и индикатором качества воды, 380 л/сутки (Россия)
Емкость из ПЭ 1500 (ЕЭЦ1500) л, цилиндрическая вертикальная для питьевой воды
Алюминиевый радиатор HLA-12R-B
Система обогрева трубопроводов SLH 25/L30 ST
Нагревательный мат FFH 400/12,0
AF11S-1A,B,С,D,E,F.Запасная сетка для F76S,СS,FK76CS и HS10S (от 1/2\" до 11/4\"), 100,20,50,200,300,500микрон
Фильтр A-11 BE (BIG BLUE 10) В сборе с кронштейном,ключом и фильтрующим элементом,1 ступень очистки (механическая)
Комплект \"TROPIX\" МНН-130-1 (1 кв. метр)
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}