using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(My|name|is|Sam) (My|name|is|Sam) (My|name|is|Sam) (My|name|is|Sam)\. (I|love|regex) (I|love|regex) (I|love|regex).";
string input = @"My Sam is name. regex I love.
name is My Sam. I regex love.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}