re = /(My|name|is|Sam) (My|name|is|Sam) (My|name|is|Sam) (My|name|is|Sam)\. (I|love|regex) (I|love|regex) (I|love|regex)./
str = 'My Sam is name. regex I love.
name is My Sam. I regex love.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end