using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s[a-zA-Z]{6}[0-9]{8}\s){1}";
string input = @" sdfs sdfs FLBREV00022230 dsfsdfs sdfsf FLBREV00022234 ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}