use strict;
my $str = 'I
II
XXIX
XXXVIII
IV
XIV
XXXIX
LXXX
XL
CCCXCIX
DCCCXCIX
CDXC
MMMCMIX
MMMCMXCIX
MMMCM
(MMMCM)CMI
(I)';
my $regex = qr/^(?!$)M{0,2}(?:M(?=CM(?:XC)?(?:IX)?$))?(?:C(?=M[^CD]*(?:XC)?[^CD]*$))?M?(?:C(?=D[^C]*(?:XC)?[^C]*$))?D?C{0,2}(?:C(?=XC(?:IX)?$))?(?:X(?=C[^X]*(?:IX)?[^X]*$)(?!.*L))?C?(?:X(?=L[^X]*(?:IX)?[^X]*$))?L?X{0,2}(?:X(?=IX$))?(?:I(?=[XV]$))?X?V?I{0,3}$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}