using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=PHPSCHOOL)PHP";
string input = @"I LOVE PHPSCHOOL BUT I DON'T LIKE PHPLANGUAGE";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}