$re = '/(?=PHPSCHOOL)PHP/';
$str = 'I LOVE PHPSCHOOL BUT I DON\'T LIKE PHPLANGUAGE';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);