#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?iu)^(http(s)?:\/\/)?(www\.)?linkedin\.([a-z]+)\/in\/[\p{L}\p{N}\p{M}_-]{3,100}\/?$"
Local $sString = "http://linkedin.com/in/mariam-el-maghrabi-b20b88167" & @CRLF & _
"https://www.linkedin.com/in/bhupad-rathi-33b69118b" & @CRLF & _
"https://www.linkedin.com/in/hassen-hamza-b7350013/" & @CRLF & _
"https://www.linkedin.com/in/safna-senna-1781a8193/" & @CRLF & _
"https://www.linkedin.com/in/balaji-mutyala-7b9a3916b/" & @CRLF & _
"https://www.linkedin.com/in/adnan-alkeba/" & @CRLF & _
"https://www.linkedin.com/in/ahmed-mouniir/" & @CRLF & _
"https://www.linkedin.com/in/louay-alshoum" & @CRLF & _
"https://linkedin.com/in/exyfi" & @CRLF & _
"https://www.linkedin.com/in/mohammed-elsheikh-889353102/" & @CRLF & _
"https://www.linkedin.com/in/%C5%9Fahin-e%C4%9Filmez-856631114/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")