# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(http(s)?:\/\/)?(www\.)?linkedin\.([a-z]+)\/in\/[\p{L}\p{N}\p{M}_-]{3,100}\/?$"
test_str = ("http://linkedin.com/in/mariam-el-maghrabi-b20b88167\n"
	"https://www.linkedin.com/in/bhupad-rathi-33b69118b\n"
	"https://www.linkedin.com/in/hassen-hamza-b7350013/\n"
	"https://www.linkedin.com/in/safna-senna-1781a8193/\n"
	"https://www.linkedin.com/in/balaji-mutyala-7b9a3916b/\n"
	"https://www.linkedin.com/in/adnan-alkeba/\n"
	"https://www.linkedin.com/in/ahmed-mouniir/\n"
	"https://www.linkedin.com/in/louay-alshoum\n"
	"https://linkedin.com/in/exyfi\n"
	"https://www.linkedin.com/in/mohammed-elsheikh-889353102/\n"
	"https://www.linkedin.com/in/%C5%9Fahin-e%C4%9Filmez-856631114/")
matches = re.search(regex, test_str, re.IGNORECASE | re.UNICODE)
if matches:
    print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
    
    for groupNum in range(0, len(matches.groups())):
        groupNum = groupNum + 1
        
        print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.