$re = '/(?:\G(?!\A)|:keyword_start:\s)(?:(?!:keyword_end:)\S+\s)*+\K\s+/';
$str = 'This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;