import re
regex = re.compile(r"(?:\G(?!\A)|:keyword_start:\s)(?:(?!:keyword_end:)\S+\s)*+\K\s+")
test_str = "This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)