using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[EAQR]:\{((\d{3}\|?)+)\}(\^([-0-9.]+))?";
string input = @"E:{300}^2&E:{800}^4&A:{201}^-1&A:{200}^0.5&Q:{400|500|700}^2&R:{201|202}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}