re = /[EAQR]:\{((\d{3}\|?)+)\}(\^([-0-9.]+))?/m
str = 'E:{300}^2&E:{800}^4&A:{201}^-1&A:{200}^0.5&Q:{400|500|700}^2&R:{201|202}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end