$re = '/(?:ProductId|Colour)%3D(\S*?)(?=%26|$)/m';
$str = 'ProductId%3D967164%26Colour%3Dbright-royal';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);