re = /(?:ProductId|Colour)%3D(\S*?)(?=%26|$)/m
str = 'ProductId%3D967164%26Colour%3Dbright-royal'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end