package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^[a-z0-9#!$%&'*+-/=?^_`{}|~]+[\.a-z0-9!#$%&'*+/=?^_`{|}~-]*[^.]@[a-z0-9]+[a-z0-9\.]*\.[a-z]{2,24}$`)
var str = `abcd@exam.fff.ffff.fff.fff.ff.ffple.com`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}