// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)^[a-z0-9#!$%&'*+-/=?^_`{}|~]+[\.a-z0-9!#$%&'*+/=?^_`{|}~-]*[^.]@[a-z0-9]+[a-z0-9\.]*\.[a-z]{2,24}$").unwrap();
let string = "abcd@exam.fff.ffff.fff.fff.ff.ffple.com";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}