using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(1.*(?<!foo|bar|baz)2)";
string input = @"1fffoo2";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}