$re = '/(1.*(?<!foo|bar|baz)2)/';
$str = '1fffoo2';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);