package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z])`)
var str = `thisIsACamelCaseWord`
var substitution = " $1"
fmt.Println(re.ReplaceAllString(str, substitution))
}