use strict;
my $str = 'thisIsACamelCaseWord';
my $regex = qr/([A-Z])/mp;
my $subst = ' $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";