const regex = /^(?:P|PICT)\d+\.\JPG$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:P|PICT)\\d+\\.\\JPG$', 'gm')
const str = `P1260407.JPG
PICT0843.JPG
PICTURE2.JPG
PICT0549.JPG`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}