$re = '/^(?:P|PICT)\d+\.\JPG$/m';
$str = 'P1260407.JPG
PICT0843.JPG
PICTURE2.JPG
PICT0549.JPG';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);