package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^[^:\s]+)\s*:\s*`)
var str = `Mon : 9:00AM - 7:00PM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}