$re = '/(^[^:\s]+)\s*:\s*/';
$str = 'Mon : 9:00AM - 7:00PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);